Integración con IOS

Posted in General by Daniel Ortiz Mon Jan 16 2017 15:30:12 GMT+0000 (UTC)·4·Viewed 35 times

Hola estoy realizado la integración con IOS , utilizando la opción automática pero al momento de usar el comando "Pod Install " el resultado es [!] The dependency `MOCA (= 1.9.6)` is not used in any concrete target. Revisando el workspace tengo <?xml version="1.0" encoding="UTF-8"?> <Workspace version = "1.0"> <FileRef location = "group:Integracion1/Integracion1.xcodeproj"> </FileRef> </Workspace> Por lo cual se que no se ha agregado la librería , como puedo solucionar esto?
Ivan Gonzalez
Jan 16, 2017
En tu `Podfile` has de definir a qué target quieres agregar la dependencia. Esto lo consigues de la siguiente manera: ``` target 'NombreDeTuTarget' do pod 'MOCA' end ``` Para saber el nombre de tu target, en Xcode haz click en tu proyecto, y mira el nombre den 'Targets' Ejemplo: ![Xcode Target](https://s3-eu-west-1.amazonaws.com/media.mocaplatform.com/images/docs/target.png)
Daniel Ortiz
Jan 16, 2017
Vale ha funcionado Muchas Gracias por tu ayuda: [!] The dependency `MOCA (= 1.9.6)` is not used in any concrete target. MacBook-Pro-de-Daniel:MocaSDK dortiz$ pod install Analyzing dependencies Downloading dependencies Installing MOCA (1.9.6) Generating Pods project Integrating client project [!] Please close any current Xcode sessions and use `MocaSDK.xcworkspace` for this project from now on. Sending stats Pod installation complete! There is 1 dependency from the Podfile and 1 total pod installed.
Daniel Ortiz
Jan 16, 2017
Hola , realizando la instalación y los pasos de este modo al realizar el debug sobre un dispositivo virtual (ipad7) la app no alcanza a construirse arrojando este stack: ld: library not found for -lPods-MocaSDK
Daniel Ortiz
Jan 16, 2017
Hola , disculpa por escribir tanto , ya solucione el problema al parecer fue algo en las descarga que fallo así que volví a realizar la instalación y perfecto
  
Markdown is allowed